Mainos / Advertisement:

RouterOS IPTV

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Tämä on käännetty versio sivusta RouterOS IPTV, ja käännös on 95 % valmis.

Muut kielet:
English • ‎suomi

Sonera Viihde IPTV functionality on Mikrotik's RouterOS operating system. By disabling VLANs it should also work with Watson.

Our hard- and software:

  • RB951G-2HnD (RouterOS 6.15)
  • Motorola VIP 1853


Download Mikrotik from their official website and install multicast-6.24rc4-mipsbe.npk into the RouterOS operating system RouterOS/en#Upgrading following these instructions. Make sure the .npk package you download is compatible with your current version of RouterOS, take a look at the names of the packets and your version number.

VLAN settings

Open the Interfaces menu.

Create a new interface VLAN 252.

 /interface vlan add name="vlan252" vlan-id=252 interface=ether1-gateway disabled=no

RouterOS iptv 8.png

Define DHCP Client and make sure you get an IP address from your ISP (Open IP -> DHCP Client).

 /ip dhcp-client add interface=vlan252 disabled=no add-default-route=no

RouterOS iptv 9.png

IGMP Proxy

Open the Routing menu -> IGMP Proxy

RouterOS iptv 1.png

RouterOS iptv 2.png

RouterOS iptv 3.png

As the interface define VLAN 252 (Not eht1 as in the picture)

RouterOS iptv 4.png

Firewall

Enable IGMP and UDP towards the inside traffic in your firewall.

RouterOS iptv 5.png

Allow firewall IGMP protocol towards the inside.

RouterOS iptv 6.png

Chain = INPUT

Protocol = UDP

ACTION = ACCEPT

RouterOS iptv 7.png

Chain = FORWARD

Protocol = UDP

ACTION = ACCEPT

You can get additional security when you only allow Interface vlan252 to the inside

Also check out

Sonera Viihde IPTV settings

Sources

http://forum.mikrotik.com/viewtopic.php?f=13&t=88169

Lähde: http://asp24.com.ua/blog/nastrojka-mikrotik-routeros-dlja-prosmotra-iptv-ot-provajdera/

Mainos / Advertisement: